Any experience on .NET-Version-Requirements?

All topics about specific development with COM interface, LIP language, API in VB, ...

Moderators: remi77, Daniel, jacs

GSus42
Private First Class
Private First Class
Posts: 12
Joined: Wed Jul 06, 2016 2:32 pm
TopSolid Version: 7.6
Location: Germany

Any experience on .NET-Version-Requirements?

Unread post by GSus42 » Thu Jul 07, 2016 4:52 pm

Update: it seems for 7.10 API-Libraries, .NET 4.5 is the requirement.


Hi,

I try to develop a prototype for using the API of TopSolid 7.10 with VisualStudio 2012.

In the TopSolid'Design Automation Guide no concrete .NET-Version is recommended.

Does anyone have experience with different .NET-Frameworks and possible consequences?


Wikipedia states that the 2.0 and 4.0-Versions respectively have changed the "Common Language Runtime"(CLR).

So is it playing safe, using 3.5 (which supports the older CLR-specs)?
Or is it safer using 4.0 since it is using the new CLR-Specs Missler build their new 7.x-API/Engine around (if even so)?
Last edited by GSus42 on Thu Jul 07, 2016 5:43 pm, edited 2 times in total.

AndiKS
Corporal
Corporal
Posts: 24
Joined: Fri Jul 31, 2009 10:43 am
TopSolid Module: TopSolid'Cam
TopSolid Version: 7.6

Re: Any experience on .NET-Version-Requirements?

Unread post by AndiKS » Thu Jul 07, 2016 5:19 pm

Hi!

I use Visual Studio 2013 with .net 4.5, both the API and Postprocessor works fine!

In one PDF Missler speak about that VS 2013 is the official supported Version...

cu
Andi

GSus42
Private First Class
Private First Class
Posts: 12
Joined: Wed Jul 06, 2016 2:32 pm
TopSolid Version: 7.6
Location: Germany

Re: Any experience on .NET-Version-Requirements?

Unread post by GSus42 » Thu Jul 07, 2016 5:41 pm

Thank you.

It seems you are right in using .NET 4.5
I just tried using 4.0. At first it seemed ok, but as I tried the first build, VISTUDIO2012 says something along the lines of:
"The primary reference to" TopSolid.Cad.Design.Automating, TopSolid.Cad.Drafting.Automating and TopSolid.Kernel.Automating respectively "... could not be used since it got build with .NET 4.5 and that is higher than the Target-Framework 4.0." (not word-by-word, translated from German)

So 4.5 seems to be the requirement for TopSolid 7.10, at least without hacking around.^^

User avatar
JuP
Master Chief
Master Chief
Posts: 127
Joined: Tue Sep 09, 2014 5:45 pm
TopSolid Module: TopSolid'Design
TopSolid Version: 7.14

Re: Any experience on .NET-Version-Requirements?

Unread post by JuP » Thu Jul 07, 2016 5:46 pm

.NET 4.5, I have never had any problem. I use VS community, it works well
https://www.visualstudio.com/fr-fr/down ... io-vs.aspx
Julien . P
Youtube
Grabcad

gmanucci
Master Corporal
Master Corporal
Posts: 49
Joined: Tue Sep 29, 2015 2:48 pm
TopSolid Module: TopSolid'Cam
TopSolid Version: 7.6

Re: Any experience on .NET-Version-Requirements?

Unread post by gmanucci » Thu Jul 07, 2016 5:54 pm

Me too, i do work with PostProcessors and API on VS 2013 community.

Post Reply