BOM Document export Decimals are commas

Forum about TopSolid'Design 7 release.

Moderators: remi77, Daniel, jacs, Romain, Bill

eric14779
Master Corporal
Master Corporal
Posts: 32
Joined: Wed May 05, 2010 1:24 am
TopSolid Module: TopSolid'Design
TopSolid Version: 7.6
Location: Upstate New York (Buffalo)

BOM Document export Decimals are commas

Unread post by eric14779 » Mon Nov 16, 2015 4:26 pm

I have my Region & Language set to USA
I have decimal to use "." (period)

but in a BOM Document decimals show as a "." (period), in the draft BOM table they show as a "," (comma)
and in a export to a CSV file they are also a "," (comma)

It should ALL be periods, I have switched my region and then switched it back, I have changed the decimal and changed it back.
no change...

anybody else have this problem, and maybe found a solution ??
Last edited by eric14779 on Thu Feb 09, 2017 7:45 pm, edited 1 time in total.

d.k.liu
Private First Class
Private First Class
Posts: 13
Joined: Mon Nov 24, 2014 1:06 pm
TopSolid Module: TopSolid'Design
TopSolid Version: 7.5

Re: BOM Document export Decimals are commas

Unread post by d.k.liu » Tue Jan 12, 2016 2:15 am

Have you solved your problem?

While I don't have the problem. It would be good to post your solutions to let others know.
Perhaps it's to do with Language setting under Options->General->Language. It seems this can be set independently for different documents so you might want to check your templates.

eric14779
Master Corporal
Master Corporal
Posts: 32
Joined: Wed May 05, 2010 1:24 am
TopSolid Module: TopSolid'Design
TopSolid Version: 7.6
Location: Upstate New York (Buffalo)

Re: BOM Document export Decimals are commas

Unread post by eric14779 » Wed Jan 13, 2016 6:51 pm

Draft language setting under Settings>General has been/is set to English USA

Problem remains 7.9.302.170

eric14779
Master Corporal
Master Corporal
Posts: 32
Joined: Wed May 05, 2010 1:24 am
TopSolid Module: TopSolid'Design
TopSolid Version: 7.6
Location: Upstate New York (Buffalo)

Re: BOM Document export Decimals are commas

Unread post by eric14779 » Tue Jan 10, 2017 9:08 pm

My work around is to export with semi-colon separator.

Then edit in notepad...........replace all semicolon with comma..... save.

Then open in Excel.... good to go...

eric14779
Master Corporal
Master Corporal
Posts: 32
Joined: Wed May 05, 2010 1:24 am
TopSolid Module: TopSolid'Design
TopSolid Version: 7.6
Location: Upstate New York (Buffalo)

Re: BOM Document export Decimals are commas

Unread post by eric14779 » Thu Feb 09, 2017 7:45 pm

They fixed it !!! in ver 7.10.301.186 maybe a couple of SP back... I did not try until this one.

Post Reply