[Solved] TopSolid 6.10 compatibility with Windows 7

Issues and questions related to TopSolid installation.

Moderators: remi77, Daniel, jacs

GrainWise
Private First Class
Private First Class
Posts: 17
Joined: Tue May 19, 2009 4:39 pm
Location: Southern Virginia

[Solved] TopSolid 6.10 compatibility with Windows 7

Unread post by GrainWise » Thu Dec 03, 2009 6:06 pm

I saw in issue #45 of the newsletter that release 7 of TopSolid is Windows 7 compatible.

I've been looking into installing Windows 7 on my computer, and was wondering if TopSolid 6.10 will run well in that environment?

Thanks!

-Kevin

User avatar
jehronimo
Major
Major
Posts: 149
Joined: Thu Mar 01, 2007 1:05 pm

Unread post by jehronimo » Fri Dec 04, 2009 9:07 am

Hello,

The answer could be "Why not?".... :) I do not work with Windows 7, but with Vista, and I just have to disable the Aero Style to have a correct behavior of the v6...I guess it works in the same way for W7....

jehronimo

User avatar
olaio
Volunteer Cadet
Volunteer Cadet
Posts: 182
Joined: Thu Mar 01, 2007 11:42 am
Location: Leiria

Unread post by olaio » Fri Dec 04, 2009 10:27 am

Hi,

I have TS7 and TS 6.10 installed in a Windows 7 x64, and they work fine.
As jehronimo said, you will need to disable the aero styles, because of graphic issues.

Olaio

User avatar
jehronimo
Major
Major
Posts: 149
Joined: Thu Mar 01, 2007 1:05 pm

Unread post by jehronimo » Fri Dec 04, 2009 10:34 am

Hi,

Thanks for the information Olaio :wink:

jehronimo

GrainWise
Private First Class
Private First Class
Posts: 17
Joined: Tue May 19, 2009 4:39 pm
Location: Southern Virginia

Unread post by GrainWise » Mon Dec 07, 2009 10:20 pm

Thanks for the replies. It's good to know that it's been done and works.

-kevin

User avatar
Larry M.
Master Chief
Master Chief
Posts: 132
Joined: Thu Apr 12, 2007 3:03 am
Location: Michigan

Unread post by Larry M. » Wed Dec 09, 2009 12:49 pm

Good news, I'm upgrading. Thank you gentlemen.

User avatar
Larry M.
Master Chief
Master Chief
Posts: 132
Joined: Thu Apr 12, 2007 3:03 am
Location: Michigan

Unread post by Larry M. » Wed Jan 20, 2010 5:10 pm

Everthing seems to be working fine. The only thing I had to do is go to Performance settings and shut off.

"Enable Desktop Composition" and "Use Visual styles on windows"


The 2nd is not necessary but it made TS look better for me. The First is necessary if you want TS2009 to save a proper image of the file when you save, otherwise it just looks like the back drop of TS when nothing is loaded.

Still have to figure out how to get it to show proper icons for ".top" files. They all have the draft document files icon in explorer.

User avatar
Larry M.
Master Chief
Master Chief
Posts: 132
Joined: Thu Apr 12, 2007 3:03 am
Location: Michigan

Unread post by Larry M. » Wed Jan 20, 2010 9:31 pm

To get the ".top" files to show the proper icon, I had to edit the registry with regedit command.

HKEY_CLASS_ROOT / TopSolid.SolidDocument / DefaultIcon

and set the value to "C:\Missler 2009\V610\bin\top610.exe,39"


You might want to do a restore point before you start messing around here, if your not sure what you are doing.

Post Reply