Page 1 of 1

[Solved] Run Time Error

Posted: Tue Nov 03, 2009 1:06 pm
by TopSolid2007
Dear friends

I have found severl crashs in TopSolid last days showing the followin error message when trying to save a .top file after some modification.

Microsoft Visual C++ Runtime Library
Program: C:\Missler2008\V69\bin\top69.exe

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Since I click in OK button, TopSolid close and I lose all modifications in this file.

My computer is an Dell Optiplex 760 with Windows XP 32bits 4GB RAM and Nvidia graphics card with 1GB memory.

Is there any thing I could do to solve it?

Another question....

Why TopSolid does not work with all CPU cores? is there a way to change it?

Thanks in advance

Anderson F. Angelucci

Posted: Tue Nov 03, 2009 1:27 pm
by Top'Noob

Is it possible for you to upgrade to the latest version of TopSolid version 6? I am having good luck with 6.10.232

Regarding multiple cores I believe the first version to take advantage of multiple cores will be TopSolid version 7. TopSolid version 7 Design is available now but the Mold and Cam modules are not yet released.

Posted: Wed Nov 04, 2009 10:37 am
by olaio
Hi TopSolid2007,

i saw that you have 4GB of RAM memory in your PC, but you have the windows XP 32 bits! Windows and TopSolid will not take advantage of those 4 GB, Windows will allow only the use of 2GB per aplication, unless you use the 3GB tunning option that will allow the use of 3GB per tunned aplication!



Posted: Wed Nov 04, 2009 4:44 pm
by TopSolid2007
Hi Olaio.

How can I use this tunning option in the 32 bits?

I am also looking for new computers, to change the ones I have here.

Does TopSolid 6 work fine with Windows 7?

I have already ready to buy 5 new computers with 8Gb, 64bit but he OS is Windows 7....

Posted: Wed Nov 04, 2009 5:32 pm
by olaio

No problem for Windows 7. I am running TopSolid 6.10 in Windows 7 64 bits, and no problem so far.

About the tunning:

1 - You need to add " /3GB" to your boot.ini
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP" /fastdetect /NoExecute=OptIn /3GB
2 - copy top610.exe to top610tunning.exe

3 - copy the file imagecfg.exe to your TopSolid instalation directory

4 - in dos mode run "imagecfg -l top610tunning.exe" in your TopSolid instalation directory

5 - copy the shortcut of your TopSolid application to the desktop.

6 - In properties of the copied shortcut, change the target top610.exe to top610tunning.exe

7 - Reboot the PC

8 - Start TopSolid with the new shortcut

That is all :wink: