Page 1 of 1

Cannot open MSSQL$SQLTOPSOLID

Posted: Mon Aug 06, 2018 9:39 pm
by John73
Just started trying to use 7.12, got the perm codes sorted out, and now it's asking me for a password to connect to my local PDM server.
connection.png
I don't remember ever setting a password, or setting up a server, or anything.

Clicking the green check mark gives me the error "Cannot open MSSQL$SQLTOPSOLID service on computer '.'."

I'm totally lost here. I've never had to do whatever this is in previous versions.

I don't use a PDM server, I just have one computer which has all my stuff on it. I've tried all sorts of things fiddling around with the "Server Connections" links, but it doesn't help. By creating a new connection and naming it something else I can get the error to say "No connection could be made because the target machine actively refused it" followed by my IP address, but that's it.

The "Don't show at startup" checkbox is taunting me. I just want this window to go away so I can get back to work.

Re: Cannot open MSSQL$SQLTOPSOLID

Posted: Mon Aug 06, 2018 10:00 pm
by Bill
Hi there,

Just hit the green check mark. It needs to logon to the new local pdm server. There is no password.

Re: Cannot open MSSQL$SQLTOPSOLID

Posted: Mon Aug 06, 2018 11:22 pm
by John73
That just gives me the error: "Cannot open MSSQL$SQLTOPSOLID service on computer '.'." and I end up back where I started.

Re: Cannot open MSSQL$SQLTOPSOLID

Posted: Tue Aug 07, 2018 11:41 am
by olaio
Hi John73

Try to run the file "TopSolid.Pdm.ServerServiceAdmin.exe" located in:
C:\Program Files\Missler Software\TopSolid 7.12\bin
you should get an icon on the notifications bar:
1.png
1.png (1.14 KiB) Viewed 7188 times
Right click on it and select the option "Manage".
You should get this:
2.png
You will need to configure your database and the vault location.

I hope this will help you...

Re: Cannot open MSSQL$SQLTOPSOLID

Posted: Tue Aug 07, 2018 5:34 pm
by John73
That window gives me this message:

Server stopped.

Failed to connect to server .\SQLTOPSOLID. A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Shared Memory Provider, error: 40 - Could not open a connection to SQL Server)

To connect to a SQL Server instance: Check that the name of the SQL Server instance is valid, you can use "Search..." to get the name of the available SQL Server instances. Check that the current Windows account is declared as a login in SQL Server instance and give the sysadmin user role to this login.


I checked the file path for the vault and it's correct. Also I'm logged in as the system administrator (not sure if that matters).

Re: Cannot open MSSQL$SQLTOPSOLID

Posted: Fri Aug 10, 2018 11:24 am
by John73
I've made several attempts to get it working, including 3 complete uninstall/reinstalls, and it's still broken. Part of the problem is that uninstall doesn't seem to remove the whole MSSQL thing, and I've tried removing that manually and reinstalling a couple of times. At one point I got it to work, sort of (it seemed as if the database vault was working, at least) but then I got stuck in a chicken-and-egg problem:

Can't connect to server without putting in my license
Can't put in my license without launching the program
Can't launch the program because the first thing it asks me to do it connect to server and won't proceed without it

So I had to uninstall that and try again, and now it's back to the same server/database errors as before.

I'm really getting quite annoyed at this. Is there somewhere I can chat directly with a tech support person?

Re: Cannot open MSSQL$SQLTOPSOLID

Posted: Fri Aug 10, 2018 6:18 pm
by remi77
Hi

In case, you've tried everything :arrow:

You may try this :arrow:

1. Uninstall all SQL Server components you can using Control Panel -> Programs and Features

2. Backup the registry.

3. Delete the following keys in regedit:

--HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server

--HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer

4. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall and delete all the sub-keys referencing SQL Server.

5. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services and delete all the keys referencing SQL Server.

6. Rename all the SQL Server folders in the computer like C:\Program Files\Microsoft SQL Server and subfolders.

In any case, preserve your data

See you

RĂ©mi :wink:

Re: Cannot open MSSQL$SQLTOPSOLID

Posted: Fri Aug 10, 2018 8:02 pm
by John73
Thank you for the reply.

I followed the instructions and the PDM server appears to be working (according to TopSolid.Pdm.ServerServiceAdmin.exe)

However when I launch the program I still have this error:
con1.png
I feel like I'm a step closer, maybe? Although I still don't understand why this is necessary when I never had to deal with it in previous versions. (My interest is mechanical engineering, not computer science)

Re: Cannot open MSSQL$SQLTOPSOLID

Posted: Fri Aug 10, 2018 11:29 pm
by John73
Okay, I ran another update and it seems to be working alright except for an issue with the license. Thank you again for your help.