API-choose which version of TopSolid you want to run

Drawing, bill of material, 2D design, dimensioning, labeling, tolerances, symbols, title blocks...

Moderators: remi77, Daniel, jacs

Post Reply
AlexAS
Private First Class
Private First Class
Posts: 10
Joined: Mon Sep 24, 2018 6:25 pm
TopSolid Module: TopSolid'Progress
TopSolid Version: 6.17

API-choose which version of TopSolid you want to run

Post by AlexAS » Fri Nov 09, 2018 10:08 am

Hello,
I have 2 version of TopSolid installed in my pc (v613 and v617).
I'm writing a vb program and I want to activate the already running TopSolid application (so I do not want to open a new window).
I'm using V6.17 and if I do:

TopApp=New TopSolid.Application

It opens a new windows with TopSolid v6.13.
Is there a way to write, for example:

TopApp= CURRENT TopSolid.application

OR

TopApp= TopSolid.application.versionXXX???


Thanks a lot

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest